Menu

How to overlay V800 heart rate, altitude and speed data to GoPro videos with DashWare

Edit February 8th, 2018: GoPro has discontinued their Developer Program, which provided software development kits (SDKs) to Polar to build connectivity to GoPro cameras. While the connectivity works for the time being, unfortunately we cannot guarantee that it will keep working in the future. You can keep making use of our GoPro features for as long as they work satisfactorily. The V800 works with the GoPro camera models and software versions listed in this document, however, support for future models and versions cannot be guaranteed.

These instructions are meant to help you get the Polar template onto your videos with DashWare. Note that DashWare is not software provided by Polar, and therefore if you need assistance using the software see the DashWare FAQ at www.dashware.net/faq/ and video tutorials at www.dashware.net/tutorial-videos/.

Overlay heart rate, altitude and speed data onto your videos from sessions with your V800 and GoPro with DashWare. Download the Polar_GoPro_Template.zip below to get a ready-made Polar template with all the needed gauges to help you get started.

Download zip file

Before getting started check that all of the following requirements are met:

  • Polar V800 firmware: You need to have version 1.11.49 or newer. Download the latest firmware onto V800 via FlowSync by connecting it to your computer with the cable.
  • GoPro HERO4 Black and Silver software: check that your camera has software version 05.00 or newer.
  • GoPro HERO5 Black software: check that your camera has software version 02.60 or newer.
  • GoPro HERO5 Session software: check that your camera has software version 02.51 or newer.
  • GoPro HERO6 Black software: check that your camera has software version 01.51 or newer.

For information and instructions on getting started and using V800 with GoPro see GoPro HERO4/HERO5/HERO6 Remote Camera Controls on Polar V800

Set up the Polar template, gauges and data profile in DashWare

You only need to set up the Polar template, data profile and gauges once in DashWare. After the initial setup, you can quickly overlay data to your videos with the Polar template.

  1. Download the Polar GoPro template zip file.
  2. Download and install DashWare onto your PC from www.dashware.net/dashware-download/
  3. Extract the Polar_GoPro_Template.zip file onto your computer.

It contains the following files:

  • The DataProfiles folder contains the Polar with GoPro.xml file.
  • The Templates folder contains Polar with Polar GoPro Template metric and Polar GoPro Template imperial folders.

Save the Polar data profile to the DashWare DataProfiles folder                                                                              

  1. Locate the DashWare DataProfiles folder on your PC. It’s usually found under Documents/Dashware.
  2. Save Polar with GoPro.xml in the DataProfiles folder.                                                                   

Save the Polar imperial and metric templates to the DashWare Templates folder           

  1. Locate the DashWare Templates folder on your PC. It’s usually found under Documents/Dashware.
  2. Save the Polar with Polar GoPro Template metric and Polar GoPro Template imperial folders in the Templates folder.  It’s usually found under Documents/Dashware.

Import Polar gauges to DashWare

  1. Open DashWare on your PC
  2. Choose the Gauge toolbox tab, and choose Import gauges.
  3. Choose DashWare Gauge Pack_Polar_imperial.dashware or DashWare Gauge Pack_Polar_metric.dashware, and choose open.
  4. Choose Add after each gauge until you’ve imported them all.
  5. The gauges are now saved, and when using a Polar template they’ll be automatically added to your video.

Overlay data to a video with the Polar template

After you’ve saved the Polar data profile, the Polar templates, and imported the Polar gauges, you’re ready to overlay data on a video with the Polar GoPro imperial or metric template.

  1. Open DashWare on your PC
  2. Choose File > New Project
  3. Name your project, and choose Polar GoPro template imperial or Polar GoPro template metric, and choose OK.
  4. In the Project tab that opens, under Input Settings choose (plus icon) after Video, and choose the video you wish to use.
  5. Choose a data profile: Choose Polar with GoPro from the list, and choose Add.
  6. When done, choose File > Create video.

Contact Us
Contact Us
Request repair
Request repair

Change region

If your country is not listed on this page, please find your local contact details, retailers and stores and service points on our global site.