Menu

What are the technical requirements for using Polar FlowSync software?

To use FlowSync you need a computer with Microsoft Windows or Mac operating system.

FlowSync 3Polar FlowSync application iconis compatible with the following operating systems:
 

     
Computer Operating System 32-bit 64-bit
Windows 7 X X
Windows 8 X X
Windows 8.1 X X
Windows 10 X X
OS X 10.9   X
OS X 10.10   X
OS X 10.11   X
macOS 10.12   X
macOS 10.13   X
macOS 10.14   X

 

For Win XP, Mac OS 10.6, 10.7, 10.8 you can still use our extended service release of FlowSync version 2. Please note that this version will no longer receive any updates and new devices from Vantage onwards are not supported.

 

Contact Us
Contact Us
Request repair
Request repair

Change region

If your country is not listed on this page, please find your local contact details, retailers and stores and service points on our global site.