Polar Flow app and compatible devices

You must first create a Polar account and register your Polar product in the Polar Flow web service before it can be paired with the Polar Flow mobile app.

Polar devices and mobile platforms
  iOS Android
Polar Loop x x
Polar Loop 2 x x
Polar Loop Crystal x x
Polar V650 x   limited*
Polar V800 x x
Polar M400 x x
Polar M450 x x
Polar A300 x x
Polar A360 x x
Polar M600 x x

*Currently syncing data between Polar V650 and Polar Flow app only works with some devices. There are several combinations of hardware and software solutions on the market at the moment, and we have been able to verify that with some devices syncing with V650 works well. Unfortunately were are not able to guarantee that syncing is consistent with all devices which meet the technical requirements.

The Polar V650 mobile sync is possible only with Android devices that meet the following requirements

  • The device runs on Android version 5.0 or newer.
  • The device can function as a Bluetooth low energy peripheral, allowing the Android device to advertise its presence to a device wanting to connect.

Compatible iOS devices

Polar Flow mobile app for iOS needs Apple’s iOS 8.0 or later.
  • iPhone 4S (only iOS 8 recommended)
  • iPhone 5
  • iPhone 5C
  • iPhone 5S
  • iPhone 6
  • iPhone 6S
  • iPhone 6 Plus
  • iPhone 6S Plus
  • iPod touch (5th generation)
  • iPad (3rd generation and newer)
  • iPad mini (1st generation and newer)
  • iPad Air
  • iPad Air 2

Compatible Android devices

Polar Flow mobile app for Android is compatible with following Android Bluetooth Smart compatible devices running Android 4.3 or later. This does not apply to Polar V650.
  • Alcatel Onetouch Idol 2S 
  • Alcatel Onetouch Hero 2 
  • Honor 6 
  • Honor 7 
  • HTC Desire 816 
  • HTC One 
  • HTC One M8 
  • HTC One Max 
  • HTC One Mini 2
  • HTC One Mini 
  • HTC One Remix 
  • Huawei Ascend P7 
  • Huawei Ascend P7 mini 
  • Huawei Y530 
  • LG F70 
  • LG G Flex 
  • LG F70 
  • LG G2 Mini 
  • LG G2 
  • LG G3 (with Android 6.0 not compatible with Loop2 and M400)
  • LG G3 S (with Android 6.0 not compatible with Loop2 and M400)
  • LG G4 (with Android 6.0 not compatible with Loop2 and M400)
  • LG G5 
  • LG L70 
  • LG L90 
  • LG Nexus 4
  • LG Nexus 5 
  • Motorola Moto E 
  • Motorola Moto E (2015) 
  • Motorola Moto G 
  • Motorola Moto G (2015) 
  • Motorola Moto X 
  • Motorola Moto X (2014) 
  • Motorola Moto X Force 
  • Oneplus One 
  • Samsung Galaxy A5 
  • Samsung Galaxy J5 
  • Samsung Galaxy Note III 
  • Samsung Galaxy Note IV 
  • Samsung Galaxy S4 
  • Samsung Galaxy S5 
  • Samsung Galaxy S6 
  • Samsung S4 Mini 
  • Samsung S5 active 
  • Samsung S5 Mini 
  • Samsung Galaxy S7
  • Samsung Trend 2 
  • Sony Xperia E1
  • Sony Xperia Z1 
  • Sony Xperia Z1 compact 
  • Sony Xperia Z2 
  • Sony Xperia T3 
  • Sony Xperia Z3 
  • Sony Xperia Z3 compact 

​We will add more devices as we test them.